using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"product: ([\w ]+)(?:version: ([\w.]+)| \w+:)";
string input = @"ftp (product: vsftpd version: 2.3.4 ostype: Unix)
product: Apache Jserv extrainfo: Protocol v1.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}