$re = '/product: ([\w ]+)(?:version: ([\w.]+)| \w+:)/mi';
$str = 'ftp (product: vsftpd version: 2.3.4 ostype: Unix)
product: Apache Jserv extrainfo: Protocol v1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);