re = /product: ([\w ]+)(?:version: ([\w.]+)| \w+:)/mi
str = 'ftp (product: vsftpd version: 2.3.4 ostype: Unix)
product: Apache Jserv extrainfo: Protocol v1.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end