package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)product: ([\w ]+)(?:version: ([\w.]+)| \w+:)`)
var str = `ftp (product: vsftpd version: 2.3.4 ostype: Unix)
product: Apache Jserv extrainfo: Protocol v1.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}