// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)product: ([\w ]+)(?:version: ([\w.]+)| \w+:)").unwrap();
let string = "ftp (product: vsftpd version: 2.3.4 ostype: Unix)
product: Apache Jserv extrainfo: Protocol v1.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}