#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:mat-column-(\w+)[^>]*>(?:<[^>]*>)*|(?<!^)\G(?:\<(?:(?!mat-column-|[><]).)*\>)*+)([^<]+)"
Local $sString = "<p>Bitte nachfolgende Transporte nach PRP einplanen:</p><table style="width: 675.406px"><colgroup><col style="width: 126px" /><col style="width: 94px" /><col style="width: 418px" /></colgroup><tbody><tr height="18" style="height: 13.6pt"><td>Transport</td><td>Owner</td><td>Short text</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCY</td><td>STENGERT</td><td>0095_PC Vorbelegung 874 MFV</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCW</td><td>STENGERT</td><td>0095_VKGr MFV 874</td></tr></tbody></table><p> </p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")