const regex = new RegExp('(?:mat-column-(\\w+)[^>]*>(?:<[^>]*>)*|(?<!^)\\G(?:\\<(?:(?!mat-column-|[><]).)*\\>)*+)([^<]+)', 'gm')
const str = `<p>Bitte nachfolgende Transporte nach PRP einplanen:</p><table style="width: 675.406px"><colgroup><col style="width: 126px" /><col style="width: 94px" /><col style="width: 418px" /></colgroup><tbody><tr height="18" style="height: 13.6pt"><td>Transport</td><td>Owner</td><td>Short text</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCY</td><td>STENGERT</td><td>0095_PC Vorbelegung 874 MFV</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCW</td><td>STENGERT</td><td>0095_VKGr MFV 874</td></tr></tbody></table><p> </p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}