$re = '/(?:mat-column-(\w+)[^>]*>(?:<[^>]*>)*|(?<!^)\G(?:\<(?:(?!mat-column-|[><]).)*\>)*+)([^<]+)/m';
$str = '<p>Bitte nachfolgende Transporte nach PRP einplanen:</p><table style="width: 675.406px"><colgroup><col style="width: 126px" /><col style="width: 94px" /><col style="width: 418px" /></colgroup><tbody><tr height="18" style="height: 13.6pt"><td>Transport</td><td>Owner</td><td>Short text</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCY</td><td>STENGERT</td><td>0095_PC Vorbelegung 874 MFV</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCW</td><td>STENGERT</td><td>0095_VKGr MFV 874</td></tr></tbody></table><p> </p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);