using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:mat-column-(\w+)[^>]*>(?:<[^>]*>)*|(?<!^)\G(?:\<(?:(?!mat-column-|[><]).)*\>)*+)([^<]+)";
string input = @"<p>Bitte nachfolgende Transporte nach PRP einplanen:</p><table style=""width: 675.406px""><colgroup><col style=""width: 126px"" /><col style=""width: 94px"" /><col style=""width: 418px"" /></colgroup><tbody><tr height=""18"" style=""height: 13.6pt""><td>Transport</td><td>Owner</td><td>Short text</td></tr><tr height=""19"" style=""height: 14.3pt""><td>DRPK9A0GCY</td><td>STENGERT</td><td>0095_PC Vorbelegung 874 MFV</td></tr><tr height=""19"" style=""height: 14.3pt""><td>DRPK9A0GCW</td><td>STENGERT</td><td>0095_VKGr MFV 874</td></tr></tbody></table><p> </p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}