use strict;
my $str = '<p>Bitte nachfolgende Transporte nach PRP einplanen:</p><table style="width: 675.406px"><colgroup><col style="width: 126px" /><col style="width: 94px" /><col style="width: 418px" /></colgroup><tbody><tr height="18" style="height: 13.6pt"><td>Transport</td><td>Owner</td><td>Short text</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCY</td><td>STENGERT</td><td>0095_PC Vorbelegung 874 MFV</td></tr><tr height="19" style="height: 14.3pt"><td>DRPK9A0GCW</td><td>STENGERT</td><td>0095_VKGr MFV 874</td></tr></tbody></table><p> </p>
';
my $regex = qr/(?:mat-column-(\w+)[^>]*>(?:<[^>]*>)*|(?<!^)\G(?:\<(?:(?!mat-column-|[><]).)*\>)*+)([^<]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}