package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[url=(.+?)]`)
var str = `ou can call my cell phone, email or text message me via my contact info on my profile.
[url=/profile/number]Click Here[/url]
Hope to hear from you all soon !!
[url=dasasdasd]asdasdasd[/url]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}