// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[url=(.+?)]").unwrap();
let string = "ou can call my cell phone, email or text message me via my contact info on my profile.
[url=/profile/number]Click Here[/url]
Hope to hear from you all soon !!
[url=dasasdasd]asdasdasd[/url]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}