re = /[url=(.+?)]/
str = 'ou can call my cell phone, email or text message me via my contact info on my profile.
[url=/profile/number]Click Here[/url]
Hope to hear from you all soon !!
[url=dasasdasd]asdasdasd[/url]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end