import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[url=(.+?)]";
final String string = "ou can call my cell phone, email or text message me via my contact info on my profile. \n\n"
+ "[url=/profile/number]Click Here[/url]\n\n"
+ "Hope to hear from you all soon !!\n\n"
+ "[url=dasasdasd]asdasdasd[/url]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}