import Foundation
let pattern = #"[url=(.+?)]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ou can call my cell phone, email or text message me via my contact info on my profile.
[url=/profile/number]Click Here[/url]
Hope to hear from you all soon !!
[url=dasasdasd]asdasdasd[/url]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)