# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(E\d)[\w\d_]+(_LLC)/$1$2/gm;t' <<< "0x010102_default_prg_L2_E2_LDep1_LLC"