$re = '/(E\d)[\w\d_]+(_LLC)/m';
$str = '0x010102_default_prg_L2_E2_LDep1_LLC';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;