package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(E\d)[\w\d_]+(_LLC)`)
var str = `0x010102_default_prg_L2_E2_LDep1_LLC`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}