// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(E\d)[\w\d_]+(_LLC)").unwrap();
let string = "0x010102_default_prg_L2_E2_LDep1_LLC";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}