use strict;
my $str = '0x010102_default_prg_L2_E2_LDep1_LLC';
my $regex = qr/(E\d)[\w\d_]+(_LLC)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";