# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http:\/\/(.*)\.eleveo.com\/auth(\/)?/http:\/\/${1}.eleveo.com\/auth\/${1}/gm;t' <<< "http://jahody.eleveo.com/auth"