re = /http:\/\/(.*)\.eleveo.com\/auth(\/)?/m
str = 'http://jahody.eleveo.com/auth'
subst = 'http://${1}.eleveo.com/auth/${1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result