// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http://(.*)\.eleveo.com/auth(/)?").unwrap();
let string = "http://jahody.eleveo.com/auth";
let substitution = "http://${1}.eleveo.com/auth/${1}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}