const regex = new RegExp('http://(.*)\\.eleveo.com/auth(/)?', 'gm')
const str = `http://jahody.eleveo.com/auth`;
const subst = `http://${1}.eleveo.com/auth/${1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);