using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http://(.*)\.eleveo.com/auth(/)?";
string substitution = @"http://${1}.eleveo.com/auth/${1}";
string input = @"http://jahody.eleveo.com/auth";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}