using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Blabla\(2\) :|(?<!^)\G).*<tr><td class=\""generic\"">(.*)<\/td>.+<\/tr>";
string input = @"2019-09-25 22:26:47.283 ERROR 2296 --- [prod-upload-9] c.a.s.t.t.service.TrendyolServiceImpl : Failed to upload 3539007 reason is could not predict the category automatically, please fill in the field aliexpress_category_id: Req: {""adminLoginId"":""tr1333351585hxnn"",""aggregationId"":""3539007"",""description"":""<ul> \n <li>Ürünlerimiz sağlığa zararlı kimyasallara karşı test edilmektedir.Ürünlerimizde bebeklerin yutabileceği küçük parçalar, tehlike oluşturabilecek ip ve kordonlar, keskin parçalar bulunmamaktadır. 2'Li Kız Bebek Desenli Mendil</li> \n</ul>"",""externalSkulInfoDTOList"":[{""price"":""399"",""skuAttributesList"":[{""skuAttributeName"":""Color"",""skuAttributeValue"":""Ekru/03E"",""skuImage"":""https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg""},{""skuAttributeName"":""Size"",""skuAttributeValue"":""One Size""}],""skuCode"":""8681976357811"",""stock"":0}],""grossWeight"":""1"",""language"":""tr"",""mainImagesList"":[""https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg""],""merchantBrandName"":""Koton Kids"",""merchantCategoryId"":""373_1"",""merchantCategoryName"":""Mendil"",""packageHeight"":30,""packageLength"":10,""packageWidth"":20,""subject"":""Koton Kids Ekru Kız Bebek 2'Li Kiz Bebek Desenli Mendil"",""thirdPartyDomain"":""TRENDYOL""}";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}