const regex = /(?:Blabla\(2\) :|(?<!^)\G).*<tr><td class=\"generic\">(.*)<\/td>.+<\/tr>/isg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Blabla\\(2\\) :|(?<!^)\\G).*<tr><td class=\\"generic\\">(.*)<\\\/td>.+<\\\/tr>', 'isg')
const str = `2019-09-25 22:26:47.283 ERROR 2296 --- [prod-upload-9] c.a.s.t.t.service.TrendyolServiceImpl : Failed to upload 3539007 reason is could not predict the category automatically, please fill in the field aliexpress_category_id: Req: {"adminLoginId":"tr1333351585hxnn","aggregationId":"3539007","description":"<ul> \\n <li>Ürünlerimiz sağlığa zararlı kimyasallara karşı test edilmektedir.Ürünlerimizde bebeklerin yutabileceği küçük parçalar, tehlike oluşturabilecek ip ve kordonlar, keskin parçalar bulunmamaktadır. 2'Li Kız Bebek Desenli Mendil</li> \\n</ul>","externalSkulInfoDTOList":[{"price":"399","skuAttributesList":[{"skuAttributeName":"Color","skuAttributeValue":"Ekru/03E","skuImage":"https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg"},{"skuAttributeName":"Size","skuAttributeValue":"One Size"}],"skuCode":"8681976357811","stock":0}],"grossWeight":"1","language":"tr","mainImagesList":["https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg"],"merchantBrandName":"Koton Kids","merchantCategoryId":"373_1","merchantCategoryName":"Mendil","packageHeight":30,"packageLength":10,"packageWidth":20,"subject":"Koton Kids Ekru Kız Bebek 2'Li Kiz Bebek Desenli Mendil","thirdPartyDomain":"TRENDYOL"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}