import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Blabla\\(2\\) :|(?<!^)\\G).*<tr><td class=\\\"generic\\\">(.*)<\\/td>.+<\\/tr>";
final String string = "2019-09-25 22:26:47.283 ERROR 2296 --- [prod-upload-9] c.a.s.t.t.service.TrendyolServiceImpl : Failed to upload 3539007 reason is could not predict the category automatically, please fill in the field aliexpress_category_id: Req: {\"adminLoginId\":\"tr1333351585hxnn\",\"aggregationId\":\"3539007\",\"description\":\"<ul> \\n <li>Ürünlerimiz sağlığa zararlı kimyasallara karşı test edilmektedir.Ürünlerimizde bebeklerin yutabileceği küçük parçalar, tehlike oluşturabilecek ip ve kordonlar, keskin parçalar bulunmamaktadır. 2'Li Kız Bebek Desenli Mendil</li> \\n</ul>\",\"externalSkulInfoDTOList\":[{\"price\":\"399\",\"skuAttributesList\":[{\"skuAttributeName\":\"Color\",\"skuAttributeValue\":\"Ekru/03E\",\"skuImage\":\"https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg\"},{\"skuAttributeName\":\"Size\",\"skuAttributeValue\":\"One Size\"}],\"skuCode\":\"8681976357811\",\"stock\":0}],\"grossWeight\":\"1\",\"language\":\"tr\",\"mainImagesList\":[\"https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg\"],\"merchantBrandName\":\"Koton Kids\",\"merchantCategoryId\":\"373_1\",\"merchantCategoryName\":\"Mendil\",\"packageHeight\":30,\"packageLength\":10,\"packageWidth\":20,\"subject\":\"Koton Kids Ekru Kız Bebek 2'Li Kiz Bebek Desenli Mendil\",\"thirdPartyDomain\":\"TRENDYOL\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}