import re
regex = re.compile(r"(?:Blabla\(2\) :|(?<!^)\G).*<tr><td class=\"generic\">(.*)<\/td>.+<\/tr>", flags=re.IGNORECASE | re.DOTALL)
test_str = "2019-09-25 22:26:47.283 ERROR 2296 --- [prod-upload-9] c.a.s.t.t.service.TrendyolServiceImpl : Failed to upload 3539007 reason is could not predict the category automatically, please fill in the field aliexpress_category_id: Req: {\"adminLoginId\":\"tr1333351585hxnn\",\"aggregationId\":\"3539007\",\"description\":\"<ul> \\n <li>Ürünlerimiz sağlığa zararlı kimyasallara karşı test edilmektedir.Ürünlerimizde bebeklerin yutabileceği küçük parçalar, tehlike oluşturabilecek ip ve kordonlar, keskin parçalar bulunmamaktadır. 2'Li Kız Bebek Desenli Mendil</li> \\n</ul>\",\"externalSkulInfoDTOList\":[{\"price\":\"399\",\"skuAttributesList\":[{\"skuAttributeName\":\"Color\",\"skuAttributeValue\":\"Ekru/03E\",\"skuImage\":\"https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg\"},{\"skuAttributeName\":\"Size\",\"skuAttributeValue\":\"One Size\"}],\"skuCode\":\"8681976357811\",\"stock\":0}],\"grossWeight\":\"1\",\"language\":\"tr\",\"mainImagesList\":[\"https://img-trendyol.mncdn.com/Assets/ProductImages/oa/60/4260756/1/8681976357811_1_org_zoom.jpg\"],\"merchantBrandName\":\"Koton Kids\",\"merchantCategoryId\":\"373_1\",\"merchantCategoryName\":\"Mendil\",\"packageHeight\":30,\"packageLength\":10,\"packageWidth\":20,\"subject\":\"Koton Kids Ekru Kız Bebek 2'Li Kiz Bebek Desenli Mendil\",\"thirdPartyDomain\":\"TRENDYOL\"}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")