const regex = /([\p{L}.'-+]+@(?:[a-z0-9.\-\p{L}]+.)+(?:[a-zA-Z0-9-\p{L}]{2,24}))/gui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\p{L}.\'-+]+@(?:[a-z0-9.\\-\\p{L}]+.)+(?:[a-zA-Z0-9-\\p{L}]{2,24}))', 'gui')
const str = `<p>Тест@домен.ком</p>
Тест@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>моят-тестов@пример.bg</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}