import re
regex = re.compile(r"([\p{L}.'-+]+@(?:[a-z0-9.\-\p{L}]+.)+(?:[a-zA-Z0-9-\p{L}]{2,24}))", flags=re.UNICODE | re.IGNORECASE)
test_str = ("<p>Тест@домен.ком</p>\n"
"Тест@домен.ком\n"
"test@domain.com\n"
"γλώσσα@τομέας.com\n"
"<p>моят-тестов@пример.bg</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")