re = /([\p{L}.'-+]+@(?:[a-z0-9.\-\p{L}]+.)+(?:[a-zA-Z0-9-\p{L}]{2,24}))/i
str = '<p>Тест@домен.ком</p>
Тест@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>моят-тестов@пример.bg</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end