# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!http:\\/\\/)(?=www)/http:\/\//gm;t' <<< "http://www.google.com
www.google.com"