import re
regex = re.compile(r"(?<!http:\/\/)(?=www)", flags=re.MULTILINE)
test_str = ("http://www.google.com\n"
"www.google.com")
subst = "http://"
result = regex.sub(subst, test_str)
if result:
print(result)