re = /(?<!http:\/\/)(?=www)/m
str = 'http://www.google.com
www.google.com'
subst = 'http://'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result