# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([0-9]*)([A-Z]?),((?:(?!\sAPP|\sAPT).)*)(?:\sAPP|\sAPT)?(.*)$/$1,$2,$3,$4/mgi;t' <<< "5847A, rue Principal APP A
5847A, rue Prince Arthur APT 22
1111, Sherwood street"