const regex = /^([0-9]*)([A-Z]?),((?:(?!\sAPP|\sAPT).)*)(?:\sAPP|\sAPT)?(.*)$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]*)([A-Z]?),((?:(?!\\sAPP|\\sAPT).)*)(?:\\sAPP|\\sAPT)?(.*)$', 'mgi')
const str = `5847A, rue Principal APP A
5847A, rue Prince Arthur APT 22
1111, Sherwood street`;
const subst = `$1,$2,$3,$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);