re = /^([0-9]*)([A-Z]?),((?:(?!\sAPP|\sAPT).)*)(?:\sAPP|\sAPT)?(.*)$/mi
str = '5847A, rue Principal APP A
5847A, rue Prince Arthur APT 22
1111, Sherwood street'
subst = '$1,$2,$3,$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result