use strict;
my $str = '5847A, rue Principal APP A
5847A, rue Prince Arthur APT 22
1111, Sherwood street';
my $regex = qr/^([0-9]*)([A-Z]?),((?:(?!\sAPP|\sAPT).)*)(?:\sAPP|\sAPT)?(.*)$/mip;
my $subst = '$1,$2,$3,$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";