#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^([0-9]*)([A-Z]?),((?:(?!\sAPP|\sAPT).)*)(?:\sAPP|\sAPT)?(.*)$"
Local $sString = "5847A, rue Principal APP A" & @CRLF & _
"5847A, rue Prince Arthur APT 22" & @CRLF & _
"1111, Sherwood street"
Local $sSubst = "$1,$2,$3,$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)