const regex = new RegExp('\\b\\s+-\\s+\\b', 'g')
const str = ` I took the pill - I realized only after I went off it how it affected my eating habits - I put on weight - around 10 lbs - in the 2.5 months on it - no control and syndrome - this was counterproductive !`;
const subst = `. `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);