// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\s+-\s+\b").unwrap();
let string = " I took the pill - I realized only after I went off it how it affected my eating habits - I put on weight - around 10 lbs - in the 2.5 months on it - no control and syndrome - this was counterproductive !";
let substitution = ". ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}