use strict;
my $str = ' I took the pill - I realized only after I went off it how it affected my eating habits - I put on weight - around 10 lbs - in the 2.5 months on it - no control and syndrome - this was counterproductive !';
my $regex = qr/\b\s+-\s+\b/p;
my $subst = '. ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";