$re = '/\b\s+-\s+\b/';
$str = ' I took the pill - I realized only after I went off it how it affected my eating habits - I put on weight - around 10 lbs - in the 2.5 months on it - no control and syndrome - this was counterproductive !';
$subst = ". ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;