use strict;
my $str = '/**
* The addVertex method checks to see if the vertex isn\'t null, and then if
* the graph does not contain the vertex, the vertex is then added and true
* is returned
*
* @param vertex
*
* @throws NullPointerException.
*
* @return b
*/';
my $regex = qr/(\* @param|@return)(.*)/mp;
my $subst = '$1$2.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";