re = /(\* @param|@return)(.*)/m
str = '/**
* The addVertex method checks to see if the vertex isn\'t null, and then if
* the graph does not contain the vertex, the vertex is then added and true
* is returned
*
* @param vertex
*
* @throws NullPointerException.
*
* @return b
*/'
subst = '$1$2.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result