using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<option.*?\s(?:selected(?:=\""selected\"")?)\s.*?>";
string input = @"<option selected=""selected"" value=""1"">value text</option>
<option selected value=""1"">value text</option>
<option value=""the devil with **selected** "">value text</option>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}