// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<option.*?\s(?:selected(?:=\"selected\")?)\s.*?>"#).unwrap();
let string = "<option selected=\"selected\" value=\"1\">value text</option>
<option selected value=\"1\">value text</option>
<option value=\"the devil with **selected** \">value text</option>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}