$re = '/<option.*?\s(?:selected(?:=\"selected\")?)\s.*?>/';
$str = '<option selected="selected" value="1">value text</option>
<option selected value="1">value text</option>
<option value="the devil with **selected** ">value text</option>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);