using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)(.+?)([a-z-]*)\/?$";
string input = @"https://something.com/a/lomg/ur-l/
http://something.com/a/lomg/url
https://something.com/a/lomg/url/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}